Change font size
It is currently Wed Oct 22, 2014 11:25 pm

Forum rules


Image
. please keep questions related to an OpenSimulator and OSgrid nature.



Post a new topicPost a reply Page 1 of 1   [ 7 posts ]
Author Message
 Post subject: Registration of Region Failed
PostPosted: Tue Nov 25, 2008 12:31 pm 

Joined: Mon Nov 24, 2008 7:58 pm
Posts: 6
Greetings all, I am new at this and I was going thru the step my step process and got was finally finished I thought till I received this error. Any assistance would be helpful.

11:13:49 - [STARTUP]: Registration of the region with the grid failed, aborting startup - System.Exception: Unable to register region with grid at http://osgrid.org:8001/. Grid services not running? ---> System.Net.WebException: The operation has timed out

Again Thank you for any help =)


Top
 Profile  
 
 Post subject: Re: Registration of Region Failed
PostPosted: Wed Nov 26, 2008 12:59 pm 
Furious Typer

Joined: Wed Oct 29, 2008 11:30 am
Posts: 67
Can you please post your OpenSim.ini file and the .xml file from the Regions folder and I will be happy to take a look and tell where you went wrong.

_________________
Thanks for listening

James Beejay
PioneerX Estate Management
http://www.sl-estates.co.uk/

For the very latest from PioneerX Estate Management please checkout our News Desk @ http://www.sl-estates.co.uk/newsdesk.php


Top
 Profile  
 
 Post subject: Re: Registration of Region Failed
PostPosted: Wed Nov 26, 2008 1:07 pm 

Joined: Mon Nov 24, 2008 7:58 pm
Posts: 6
Thanks so much James, posting it now.

opensim.ini

[Startup]
gridmode = True
meshing = ZeroMesher
;meshing = Meshmerizer
; Choose one of the physics engines below
;physics = basicphysics
;physics = POS
physics = OpenDynamicsEngine
;physics = modified_BulletX
physical_prim = True
asset_database = "grid"
see_into_this_sim_from_neighbor = True
serverside_object_permissions = True
;storage_plugin = OpenSim.Data.SQLite.dll
;storage_connection_string = URI=file:OpenSim.db,version=3
storage_plugin="OpenSim.Data.MySQL.dll"
storage_connection_string="Data Source=localhost;Database=opensim;User ID=root;Password=;"
storage_prim_inventories = True
startup_console_commands_file =
shutdown_console_commands_file =
DefaultScriptEngine = ScriptEngine.DotNetEngine
;asset_plugin = "OpenSim.Data.SQLite.dll"
asset_plugin = "OpenSim.Data.MySQL.dll"
clientstack_plugin = OpenSim.Region.ClientStack.LindenUDP.dll
[StandAlone]
accounts_authenticate = False
welcome_message = Welcome to OpenSimulator
inventory_plugin = OpenSim.Data.MySQL.dll
inventory_source = "Data Source=localhost;Database=opensim;User ID=root;Password=;"
userDatabase_plugin = OpenSim.Data.MySQL.dll
user_source = "Data Source=localhost;Database=opensim;User ID=root;Password=;"
asset_plugin = OpenSim.Data.MySQL.dll
asset_source = "Data Source=localhost;Database=opensim;UserID=root;Password=;"
dump_assets_to_file = False
[Network]
default_location_x = 10003
default_location_y = 10020
http_listener_port = 9000
remoting_listener_port = 8895
grid_server_url = http://osgrid.org:8001/
grid_send_key = "1234"
grid_recv_key = "1234"
user_server_url = http://osgrid.org:8002/
user_send_key = "1234"
user_recv_key = "1234"
asset_server_url = http://osgrid.org:8003/
inventory_server_url = http://osgrid.org:8004/
secure_inventory_server = true


default.xml

<Root>
<Config sim_UUID="8453a3c1-1380-49e4-8979-3e6c4f5d069c" sim_name="OpenSkyConsulting" sim_location_x="10003" sim_location_y="10020" internal_ip_address="0.0.0.0" internal_ip_port="9000" allow_alternate_ports="false" external_host_name="70.157.22.26" master_avatar_uuid="00000000-0000-0000-0000-000000000000" master_avatar_first="Omen" master_avatar_last="Crow" master_avatar_pass="" lastmap_uuid="416e887c-ffb5-4358-99d9-f1809370259c" lastmap_refresh="1227554826" />
</Root>


Last edited by Omen Crow on Wed Nov 26, 2008 1:28 pm, edited 1 time in total.

Top
 Profile  
 
 Post subject: Re: Registration of Region Failed
PostPosted: Wed Nov 26, 2008 1:13 pm 
Furious Typer

Joined: Wed Oct 29, 2008 11:30 am
Posts: 67
Ok, 2 things to mention first off........

Please edit you post and remove your password fromthe SQL details or you give everyone access to your database. Second there is little wrong with your ini or xml, which leaves just 2 things.....

1. The region is already taken, this is often mentioned in the error message so is least likly.
2. You need to check your router for port forwarding, you will forward ports 8895->9005 to your machine specifically. The ones inthe 889X range are the grid interface, the 900x arfe the interfaces for the regions you have on your system.

_________________
Thanks for listening

James Beejay
PioneerX Estate Management
http://www.sl-estates.co.uk/

For the very latest from PioneerX Estate Management please checkout our News Desk @ http://www.sl-estates.co.uk/newsdesk.php


Top
 Profile  
 
 Post subject: Re: Registration of Region Failed
PostPosted: Wed Nov 26, 2008 1:55 pm 

Joined: Mon Nov 24, 2008 7:58 pm
Posts: 6
Thanks James, I think its the port forwarding as I have not done this yet. Again thanks =)
will give it a whirl and let you know how I do and I have changed my passwords already. I cant believe I missed that.


Top
 Profile  
 
 Post subject: Re: Registration of Region Failed
PostPosted: Wed Nov 26, 2008 5:52 pm 

Joined: Mon Nov 24, 2008 7:58 pm
Posts: 6
Ok, I have my port forwarding set up correctly, now I am getting a new error msg. Based on the message I am guessing my issue is I am trying to connect my sim to the grid with a desktop running xp pro instead. I also checked the grid space I am trying to connect to and it looks empty

16:16:58 - [STARTUP]: Registration of region with grid failed, aborting startup id service could not contact the http url http://(my external ip):9000/simstatus/ at your region. Please make sure this url is reachable by the grid service

Here are my updated ini and xml
opensim.ini

[Startup]
gridmode = True
meshing = ZeroMesher
;meshing = Meshmerizer
; Choose one of the physics engines below
;physics = basicphysics
;physics = POS
physics = OpenDynamicsEngine
;physics = modified_BulletX
physical_prim = True
asset_database = "grid"
see_into_this_sim_from_neighbor = True
serverside_object_permissions = True
;storage_plugin = OpenSim.Data.SQLite.dll
;storage_connection_string = URI=file:OpenSim.db,version=3
storage_plugin="OpenSim.Data.MySQL.dll"
storage_connection_string="Data Source=localhost;Database=opensim;User ID=root;Password=***********;"
storage_prim_inventories = True
startup_console_commands_file =
shutdown_console_commands_file =
DefaultScriptEngine = ScriptEngine.DotNetEngine
;asset_plugin = "OpenSim.Data.SQLite.dll"
asset_plugin = "OpenSim.Data.MySQL.dll"
clientstack_plugin = OpenSim.Region.ClientStack.LindenUDP.dll
[StandAlone]
accounts_authenticate = False
welcome_message = Welcome to OpenSimulator
inventory_plugin = OpenSim.Data.MySQL.dll
inventory_source = "Data Source=localhost;Database=opensim;User ID=root;Password=***********;"
userDatabase_plugin = OpenSim.Data.MySQL.dll
user_source = "Data Source=localhost;Database=opensim;User ID=root;Password=***********;"
asset_plugin = OpenSim.Data.MySQL.dll
asset_source = "Data Source=localhost;Database=opensim;UserID=root;Password=***********;"
dump_assets_to_file = False
[Network]
default_location_x = 10003
default_location_y = 10020
http_listener_port = 9000
remoting_listener_port = 8895
grid_server_url = http://osgrid.org:8001/
grid_send_key = "1234"
grid_recv_key = "1234"
user_server_url = http://osgrid.org:8002/
user_send_key = "1234"
user_recv_key = "1234"
asset_server_url = http://osgrid.org:8003/
inventory_server_url = http://osgrid.org:8004/
secure_inventory_server = true

default.xml

<Root>
<Config sim_UUID="8453a3c1-1380-49e4-8979-3e6c4f5d069c" sim_name="OpenSkyConsulting" sim_location_x="10003" sim_location_y="10020" internal_ip_address="(my internal IP)" internal_ip_port="9000" allow_alternate_ports="false" external_host_name="(my external IP)" master_avatar_uuid="00000000-0000-0000-0000-000000000000" master_avatar_first="Omen" master_avatar_last="Crow" master_avatar_pass="**********" lastmap_uuid="fd2967ac-6189-48c8-8125-b3d3e56e1e1e" lastmap_refresh="1227729660" />
</Root>


Top
 Profile  
 
 Post subject: Re: Registration of Region Failed
PostPosted: Fri Nov 28, 2008 11:53 am 
Furious Typer

Joined: Wed Oct 29, 2008 11:30 am
Posts: 67
This message is generated from the process that connects your region with the grid.....when in grid mode there is a procedure during server startup that registers your region with the grid server at OSGrid and then that region server tries to question your OpenSim server in return to get the status of your region this is essentially a double check to make sure 2 way comunication has been estabilished. I would suspect as your running XP your Windows Firewall or another software firewal on the machine has not bee told that it must allow ports 889x->900x through.

When the grid server at OSGrid tries to connection to the OpenSim instance on your machine I suspect your windows firewall is blocking the incvomming traffic as 'unsolicited'

_________________
Thanks for listening

James Beejay
PioneerX Estate Management
http://www.sl-estates.co.uk/

For the very latest from PioneerX Estate Management please checkout our News Desk @ http://www.sl-estates.co.uk/newsdesk.php


Top
 Profile  
 
Display posts from previous:  Sort by  
Post a new topicPost a reply Page 1 of 1   [ 7 posts ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  


Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
610nm Style by Daniel St. Jules of Gamexe.net