Change font size
It is currently Fri Aug 17, 2018 7:46 am

Forum rules


{L_IMAGE}
. please keep questions related to an OpenSimulator and OSgrid nature.



Post a new topicPost a reply Page 1 of 1   [ 4 posts ]
Author Message
 Post subject: My sim doesn't get registered in search
PostPosted: Wed Apr 25, 2018 12:00 pm 
User avatar

Joined: Thu Mar 19, 2015 9:52 am
Posts: 27
Hiya, my sim (Kinky Hub) doesn't get registered in search.

Datasnapshot is enabled and the parcel (simwide) is ticked to be shown in search along with a parcel description. I even tried deleting the sim and starting from scratch with a fresh new UUID (sadly killing all landmarks people might have).

I also noticed a lot of parcels in search on non-existant sims. Does the search service not get daily purged of parcels on sims that are non-existing?

Speaking of purging old stuff, why is there no daily cronjob that deletes old group notices? I see notices dating back several years! The same (a cronjob) could be done for groups that have zero or just 1 member. Yes, the first of such a query will be pretty intensive, but subsequent purges will be fast if done on a regular interval.


Top
 Profile  
 
 Post subject: Re: My sim doesn't get registered in search
PostPosted: Wed May 16, 2018 3:29 am 
Site Admin
User avatar

Joined: Sun Jun 27, 2010 10:34 am
Posts: 106
Location: France
This is much more complicated than a simple cron job, so the search is still in the development stage as well as the groups.
You have to be patient for a day, we have crons that work all day for many services added i do not think it is a solution for the reliability of servers.
The developers (opensim) should lean a little more on services as groups and research to my taste leaves a drop of abandonment. :shock:

_________________
Paela Argus,
Webmanagement Osgrid

https://www.osgrid.org


Top
 Profile  
 
 Post subject: Re: My sim doesn't get registered in search
PostPosted: Mon Jul 30, 2018 11:41 pm 
User avatar

Joined: Thu Mar 19, 2015 9:52 am
Posts: 27
Hiya just a followup in the hope it helps others :)

Turns out it didn't work because I left externalhostname set to SYSTEMIP in the region ini file. After changing it to the servers' hostname (FQDN) the region (Kinky Hub) has registered in search now.

I agree the search module could use some love.


Top
 Profile  
 
 Post subject: Re: My sim doesn't get registered in search
PostPosted: Thu Aug 16, 2018 9:54 pm 

Joined: Thu Aug 16, 2018 6:41 am
Posts: 4
Hi Lotek,
I know this is an older thread, but I found Knky Hub on the search, but was unable to TP to it and on the map it was down as an invalid region.

Regards
The Baron

(p.s. IM sent in world)


Top
 Profile  
 
Display posts from previous:  Sort by  
Post a new topicPost a reply Page 1 of 1   [ 4 posts ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron


Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
610nm Style by Daniel St. Jules of Gamexe.net