Change font size
It is currently Tue Nov 12, 2019 3:21 am

Forum rules


{L_IMAGE}
. please keep questions related to an OpenSimulator and OSgrid nature.



Post a new topicPost a reply Page 1 of 1   [ 2 posts ]
Author Message
 Post subject: Unable to change settings in "About Land"
PostPosted: Wed Aug 21, 2019 1:11 pm 

Joined: Wed Aug 21, 2019 12:48 pm
Posts: 1
I am unable to change any of the Options, Media, Sound and Access Tabs in "About Land". The General and Objects Tabs seem to work as expected.
This is only a recent problem prior to this week I have been able to change the settings.

I had the land assigned to my personnal Group, I tried deeding the land to the Group with no luck. Reclaimed the Land and still no luck and I have done that on both regions.

I have searched Google and had no luck finding a solution I have also searched this Forum without any luck.

I have 2 Regions currently as I'm in the process of moving from one to the other and the problem exists in both regions.

1st region is Location = 10160,10142
SizeX = 1024
SizeY = 1024
SizeZ = 256
Running on osgrid-opensim-11262018.v0.9.1.dc9f0d3

2nd region is Location = 10165,9946
SizeX = 2304
SizeY = 2304
SizeZ = 256
Running on osgrid-opensim-05142019.v.9.0.1.0e2adbe

I have used Firestorm-Releasex64 6.0.2 56680 as well as Singularity Viewer (64 bit) 1.8.7 (6994) Apr 9 2018 02:54:48 (Singularity Alpha).
The issue is the same using both.

I have checked Opensim.ini and Groups are enabled.

I am still able to terraform in both regions and the Region Details dialog still appears to work on both regions.

Hope someone can show me the stupid mistake I'm making. Thanks in anticipation :)


Top
 Profile  
 
 Post subject: Re: Unable to change settings in "About Land"
PostPosted: Thu Aug 22, 2019 5:12 am 
Site Admin

Joined: Sun Jul 04, 2010 8:20 pm
Posts: 487
This is a problem introduced with .Net 4.8 (i.e. windows update 1903)

there are two ways to resolve this at the moment, one is to force the simulator to use the older Jit

those with .net4.8 please try this:
in files OpenSim.exe.config, OpenSim32.exe.config and Robust.exe.config in section RunTime, add the line:

<useLegacyJit enabled="1" />

ie where it reads:

<runtime>
<loadFromRemoteSources enabled="true" />
</runtime>

change to:

<runtime>
<loadFromRemoteSources enabled="true" />
<useLegacyJit enabled="1" />
</runtime>

this should disable the new (broken) JIT reverting to the one of .net4.5(?)
bad, but not as bad as running all in Debug mode.


The other solution is to update to latest code that has been fixed to work with the newer Jit

Hope this helps


Top
 Profile  
 
Display posts from previous:  Sort by  
Post a new topicPost a reply Page 1 of 1   [ 2 posts ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  


Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
610nm Style by Daniel St. Jules of Gamexe.net