Change font size
It is currently Sat Feb 16, 2019 12:57 am

Forum rules


{L_IMAGE}
. please keep questions related to an OpenSimulator and OSgrid nature.



Post a new topicPost a reply Page 1 of 1   [ 6 posts ]
Author Message
 Post subject: Error Loading an IAR
PostPosted: Fri Dec 25, 2015 12:40 am 

Joined: Sat Nov 21, 2015 8:16 pm
Posts: 6
I have never seen this error message before, while loading an IAR:

{L_CODE}:
[Assets]: Upload failed: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx - Requeuing asset for another run


Not just one, but multiple ones. The IAR appears to load assets (showing up in inventory), but since these are open source IARs, I have no clue which assets could possibly be failing. The Requeuing asset for another run part of the message is what's puzzling - another run of what? The load iar? I am going to try rerunning the load iar with merge to see if anything else loads.

Any thoughts? BTW, running OpenSim v0.9.0.e095f51 on Linux (Debian).

AW


Top
 Profile  
 
 Post subject: Re: Error Loading an IAR
PostPosted: Sat Dec 26, 2015 10:10 am 
Site Admin

Joined: Sun Jul 04, 2010 8:20 pm
Posts: 480
this might just be debug messages that were not in the previous versions.. I uploaded a couple of iars on 0.9.0 and they seemed a little spammy, requeuing assets, etc but the end result was successful

dan


Top
 Profile  
 
 Post subject: Re: Error Loading an IAR
PostPosted: Sat Dec 26, 2015 6:52 pm 

Joined: Sat Nov 21, 2015 8:16 pm
Posts: 6
Thanks, Dan - loaded a small one, got the messages, nothing missing!

AW


Top
 Profile  
 
 Post subject: Re: Error Loading an IAR
PostPosted: Thu Apr 14, 2016 12:59 pm 

Joined: Wed Apr 13, 2011 8:39 am
Posts: 9
Spammy does not begin to do justice to the number of messages received. This message seems to appear three times for each uploaded inventory item. At this point in the (large) IAR upload (which hasn't completed) I have over 8,000 of these warning messages in my log. They are all for a single IAR load operation.

Since the console and log are both full of these spam messages, you have to search the log to find real error messages such as:

2016-04-14 13:18:31,103 ERROR (1) - OpenSim.Region.Framework.Scenes.Serialization.CoalescedSceneObjectsSerializer [COALESCED SCENE OBJECTS SERIALIZER]: Deserialization of xml failed
System.Xml.XmlException: Root element is missing.
at System.Xml.XmlTextReaderImpl.Throw(Exception e)
at System.Xml.XmlTextReaderImpl.ParseDocumentContent()
at System.Xml.XmlReader.MoveToContent()
at OpenSim.Region.Framework.Scenes.Serialization.CoalescedSceneObjectsSerializer.TryFromXml(String xml, CoalescedSceneObjects& coa) in k:\OSGRID\opensim-0.9.0-284-ged9d4fe\OpenSim\Region\Framework\Scenes\Serialization\CoalescedSceneObjectsSerializer.cs:line 136
2016-04-14 13:18:31,119 ERROR (1) - OpenSim.Framework.Util [COALESCED SCENE OBJECTS SERIALIZER]: Failed XML (0 bytes) =
2016-04-14 13:18:31,119 ERROR (1) - OpenSim.Region.Framework.Scenes.Serialization.SceneObjectSerializer [SERIALIZER]: Deserialization of xml failed
System.Xml.XmlException: 'None' is an invalid XmlNodeType. Line 1, position 1.
at System.Xml.XmlReader.ReadStartElement(String name)
at OpenSim.Region.Framework.Scenes.Serialization.SceneObjectSerializer.Xml2ToSOP(XmlReader reader) in k:\OSGRID\opensim-0.9.0-284-ged9d4fe\OpenSim\Region\Framework\Scenes\Serialization\SceneObjectSerializer.cs:line 1717
at OpenSim.Region.Framework.Scenes.SceneObjectPart.FromXml(XmlReader xmlReader) in k:\OSGRID\opensim-0.9.0-284-ged9d4fe\OpenSim\Region\Framework\Scenes\SceneObjectPart.cs:line 2466
at OpenSim.Region.Framework.Scenes.Serialization.SceneObjectSerializer.FromOriginalXmlFormat(XmlReader reader) in k:\OSGRID\opensim-0.9.0-284-ged9d4fe\OpenSim\Region\Framework\Scenes\Serialization\SceneObjectSerializer.cs:line 95
at OpenSim.Region.Framework.Scenes.Serialization.SceneObjectSerializer.FromOriginalXmlFormat(String xmlData) in k:\OSGRID\opensim-0.9.0-284-ged9d4fe\OpenSim\Region\Framework\Scenes\Serialization\SceneObjectSerializer.cs:line 69
2016-04-14 13:18:31,119 ERROR (1) - OpenSim.Framework.Util [SERIALIZER]: Failed XML (0 bytes) =

Of course, all this second error message tells you is that there's an error somewhere in the IAR file but gives no hint as to what object might have caused it so it's kind of useless too.


Top
 Profile  
 
 Post subject: Re: Error Loading an IAR
PostPosted: Fri Jan 25, 2019 6:13 pm 
Furious Typer
User avatar

Joined: Mon Mar 22, 2010 4:01 pm
Posts: 102
Location: Canada
[quote="dan banner"]this might just be debug messages that were not in the previous versions.. I uploaded a couple of iars on 0.9.0 and they seemed a little spammy, requeuing assets, etc but the end result was successful

dan[/quote]

I've been having nothing but this same issue for the past week of various attempts at it, including folder by folder backups .I had no problems importing the IAR I saved from OSG to Diva but the reverse seems to be quite problematic.

Was there ever a follow up to this issue because I get nothing but CONSTANT issue of this error: (the UUIDs vary but the message is consistent.)

17:58:15 - [Assets]: Upload failed: xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx type 20 will retry later

And then... it goes on and on and on... ad infinitum.

_________________
<3 Foxxe <3


Top
 Profile  
 
 Post subject: Re: Error Loading an IAR
PostPosted: Sat Jan 26, 2019 7:38 am 
Site Admin
User avatar

Joined: Sun Jun 27, 2010 10:34 am
Posts: 140
Location: France
:o stop save iar all time please !!!!
grrrrrrrrrrrrrrrrrrrrrrrrr

_________________
Paela Argus,
Webmanagement Osgrid

https://www.osgrid.org


Top
 Profile  
 
Display posts from previous:  Sort by  
Post a new topicPost a reply Page 1 of 1   [ 6 posts ]


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron


Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
610nm Style by Daniel St. Jules of Gamexe.net