Change font size
It is currently Tue Sep 18, 2018 7:56 pm

Forum rules


{L_IMAGE}
. please keep questions related to an OpenSimulator and OSgrid nature.



Post a new topicPost a reply Page 1 of 1   [ 6 posts ]
Author Message
 Post subject: Shutdown No Save Objects
PostPosted: Mon Feb 19, 2018 1:11 am 

Joined: Mon Feb 19, 2018 1:03 am
Posts: 2
hi all
how do i make the database Save Objects when shutting down my Region?
i get lots of Errors look below

2018-02-19 05:53:49,714 ERROR [SCENE]: Storing of Object, 7bd6b7ef-6267-43c5-9d2c-696096ebc559 in Slollywood-Town failed with exception Library used incorrectly
library routine called out of sequence at System.Data.Common.DbDataAdapter.UpdatedRowStatusErrors(RowUpdatedEventArgs rowUpdatedEvent, BatchCommandInfo[] batchCommands, Int32 commandCount)
at System.Data.Common.DbDataAdapter.UpdatedRowStatus(RowUpdatedEventArgs rowUpdatedEvent, BatchCommandInfo[] batchCommands, Int32 commandCount)
at System.Data.Common.DbDataAdapter.Update(DataRow[] dataRows, DataTableMapping tableMapping)
at System.Data.Common.DbDataAdapter.UpdateFromDataTable(DataTable dataTable, DataTableMapping tableMapping)
at System.Data.Common.DbDataAdapter.Update(DataSet dataSet, String srcTable)
at OpenSim.Data.SQLite.SQLiteSimulationData.Commit() in k:\OSGRID\opensim-0.9.1-1713-g1e3cb82\OpenSim\Data\SQLite\SQLiteSimulationData.cs:line 1117
at OpenSim.Data.SQLite.SQLiteSimulationData.StoreObject(SceneObjectGroup obj, UUID regionUUID) in k:\OSGRID\opensim-0.9.1-1713-g1e3cb82\OpenSim\Data\SQLite\SQLiteSimulationData.cs:line 631
at OpenSim.Services.SimulationService.SimulationDataService.StoreObject(SceneObjectGroup obj, UUID regionUUID) in k:\OSGRID\opensim-0.9.1-1713-g1e3cb82\OpenSim\Services\SimulationService\SimulationDataService.cs:line 84
at OpenSim.Region.Framework.Scenes.SceneObjectGroup.ProcessBackup(ISimulationDataService datastore, Boolean forcedBackup) in k:\OSGRID\opensim-0.9.1-1713-g1e3cb82\OpenSim\Region\Framework\Scenes\SceneObjectGroup.cs:line 2544
2018-02-19 05:53:49,715 DEBUG [SCENE]: Closing scene


but get many of the objects reporting this, when shutdown, anyone know how to solve this, is it the database, or something else ? just want to get to the bottom of it, so i can correct it.
Yours thanks
Acen8


Top
 Profile  
 
 Post subject: Re: Shutdown No Save Objects
PostPosted: Mon Feb 19, 2018 6:06 am 
Site Admin

Joined: Sun Jul 04, 2010 8:20 pm
Posts: 475
Do you have directory permissions set correctly? You could try running as administrator and/or right click the folder and select Properties, Security, select EDIT button, Select ADD button, Add your user name on the PC and give that account FULL CONTROL. (This varies a little between versions of Windows)

dan


Top
 Profile  
 
 Post subject: Re: Shutdown No Save Objects
PostPosted: Thu Feb 22, 2018 11:29 pm 

Joined: Mon Feb 19, 2018 1:03 am
Posts: 2
hi dan
yes i tryed all that it Did have read and write only. i have tried every thing to get it out of that, done the full security thing and even other stuff but still getting same Errors. it Really annoying me now, now what i have to do is load from a backup oar files every time its a pain in the Ass, Grrrr


Top
 Profile  
 
 Post subject: Re: Shutdown No Save Objects
PostPosted: Mon Jun 18, 2018 1:25 am 

Joined: Mon Jun 18, 2018 1:13 am
Posts: 2
Not sure if this helps. I was having the same issue yesterday with losing items trying to be saved. Running Opensim 0.9, on win7

Storing of XXX failed with exception Library used incorrectly
library routine called out of sequence at System.Data.Common.......
for EVERY item on my region....

anyway, I had just did a windows update which included an update to .Net, I had either 4.5.2 installed or 4.6 something, don't remember, sorry.... after this update is when things got all borked.

Ended up uninstalling the .Net Framework 4.5.2.... (or whichever it was)

.Net Framework 3.5 will not work with opensim on my system.

I installed .Net Framework 4.5 and everything is running absolutely perfectly again, no errors, nothing. Reloaded my region and no objects missing.

I am in no way computer savvy, I pretty much just poke at my machine with a stick (for HOURS) and hope it works so figuring this out was a huge win for me!

*** Edit: Forgot to mention that I also uninstalled the latest update for MS Visual C++ 2005 Redist (which was in the clump of updates I did). Think this might be impo too... ?

It's an old thread, but I hope it helps someone out there.


Top
 Profile  
 
 Post subject: Re: Shutdown No Save Objects
PostPosted: Mon Jun 18, 2018 9:16 am 
Site Admin
User avatar

Joined: Fri May 14, 2010 2:09 pm
Posts: 193
Location: Netherlands
http://opensimulator.org/wiki/Dependencies

Could still fail due to language / locale settings, even if running the correct .NET framework.
Opensim requires .NET framework 4. Just 3.5 will not work unless you use some very ancient version.


Top
 Profile  
 
 Post subject: Re: Shutdown No Save Objects
PostPosted: Tue Jun 19, 2018 2:40 am 

Joined: Mon Jun 18, 2018 1:13 am
Posts: 2
@Foxx Bode: no sooner did I put that post and it happened again on shutdown....same errors as first poster listed....
UNLESS I run the simulator from a different drive other than my C drive? (ex: I put a copy of the opensim folder on a different drive and ran the simulator, everything loaded and saved with no issue...)

Back to poking with stick...

(btw, didn't know language and locale settings could cause a problem, learning as I go along, good to know for future issues, thank you for that)


Top
 Profile  
 
Display posts from previous:  Sort by  
Post a new topicPost a reply Page 1 of 1   [ 6 posts ]


Who is online

Users browsing this forum: No registered users and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  


Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
610nm Style by Daniel St. Jules of Gamexe.net