Change font size
It is currently Thu Dec 03, 2020 2:26 am

Forum rules


{L_IMAGE}
. please keep questions related to an OpenSimulator and OSgrid nature.



Post a new topicPost a reply Page 1 of 1   [ 2 posts ]
Author Message
 Post subject: Fatal error: System.Net.Sockets.SocketException (0x80004005)
PostPosted: Sat Jul 11, 2020 7:15 am 

Joined: Sat Jul 11, 2020 6:59 am
Posts: 1
Hi peeps.

I'm trying to set up an open sim region and failing miserably.

Since I dont have access to broadband I'm haveing to use my 4g unlimited data in a google pixel wich isnt Ideal but gets me internet.

I can use Ngrok to make a tunnel for porting wich I know works for the tcp (verified setting up an MC server) and I belive i can rout the udp through that aswell with another service. But before I can even get that far, My server console just keeps crashing on startup.
Even when I just use my public ip with no tunneling wich has atleast booted the server in the past, Though porting failed at that time.

Looking at the log I see this

"2020-07-11 12:48:06,722 FATAL Fatal error: System.Net.Sockets.SocketException (0x80004005): The requested address is not valid in its context
at System.Net.Sockets.Socket.DoBind(EndPoint endPointSnapshot, SocketAddress socketAddress)
at System.Net.Sockets.Socket.Bind(EndPoint localEP)
at OpenMetaverse.OpenSimUDPBase.StartInbound(Int32 recvBufferSize) in K:\OSGRID\opensim-0.9.2.0Dev-391-gb598573\OpenSim\Region\ClientStack\Linden\UDP\OpenSimUDPBase.cs:line 299
at OpenSim.Region.ClientStack.LindenUDP.LLUDPServer.StartInbound() in K:\OSGRID\opensim-0.9.2.0Dev-391-gb598573\OpenSim\Region\ClientStack\Linden\UDP\LLUDPServer.cs:line 482
at OpenSim.Region.ClientStack.LindenUDP.LLUDPServer.Start() in K:\OSGRID\opensim-0.9.2.0Dev-391-gb598573\OpenSim\Region\ClientStack\Linden\UDP\LLUDPServer.cs:line 469
at OpenSim.Region.ClientStack.LindenUDP.LLUDPServerShim.Start() in K:\OSGRID\opensim-0.9.2.0Dev-391-gb598573\OpenSim\Region\ClientStack\Linden\UDP\LLUDPServer.cs:line 234
at OpenSim.Region.ClientStack.LindenUDP.LLUDPServerShim.RegionLoaded(Scene scene) in K:\OSGRID\opensim-0.9.2.0Dev-391-gb598573\OpenSim\Region\ClientStack\Linden\UDP\LLUDPServer.cs:line 99
at OpenSim.ApplicationPlugins.RegionModulesController.RegionModulesControllerPlugin.AddRegionToModules(Scene scene) in K:\OSGRID\opensim-0.9.2.0Dev-391-gb598573\OpenSim\ApplicationPlugins\RegionModulesController\RegionModulesControllerPlugin.cs:line 510
at OpenSim.OpenSimBase.CreateRegion(RegionInfo regionInfo, Boolean portadd_flag, Boolean do_post_init, IScene& mscene) in K:\OSGRID\opensim-0.9.2.0Dev-391-gb598573\OpenSim\Region\Application\OpenSimBase.cs:line 452
at OpenSim.OpenSimBase.CreateRegion(RegionInfo regionInfo, Boolean portadd_flag, IScene& scene) in K:\OSGRID\opensim-0.9.2.0Dev-391-gb598573\OpenSim\Region\Application\OpenSimBase.cs:line 387
at OpenSim.ApplicationPlugins.LoadRegions.LoadRegionsPlugin.PostInitialise() in K:\OSGRID\opensim-0.9.2.0Dev-391-gb598573\OpenSim\ApplicationPlugins\LoadRegions\LoadRegionsPlugin.cs:line 130
at OpenSim.OpenSimBase.StartupSpecific() in K:\OSGRID\opensim-0.9.2.0Dev-391-gb598573\OpenSim\Region\Application\OpenSimBase.cs:line 285
at OpenSim.OpenSim.StartupSpecific() in K:\OSGRID\opensim-0.9.2.0Dev-391-gb598573\OpenSim\Region\Application\OpenSim.cs:line 217
at OpenSim.Framework.Servers.BaseOpenSimServer.Startup() in K:\OSGRID\opensim-0.9.2.0Dev-391-gb598573\OpenSim\Framework\Servers\BaseOpenSimServer.cs:line 204 "

I'm doing all this on windows 10 with .net 4.8 installed and my firewall turned off incase that was causeing an issue. Also myosgrid is installed on my F drive. I dont have a K drive so I dont know where thats comming from unless thats the OSgrid servers.

I also wiped off the old installation and redownloaded the latest build from the opengrid website. Any thoughts would be appriciated


Top
 Profile  
 
 Post subject: Re: Fatal error: System.Net.Sockets.SocketException (0x80004005)
PostPosted: Mon Jul 13, 2020 7:50 am 
Site Admin
User avatar

Joined: Fri May 14, 2010 2:09 pm
Posts: 252
Location: Netherlands
"2020-07-11 12:48:06,722 FATAL Fatal error: System.Net.Sockets.SocketException (0x80004005): The requested address is not valid in its context
at System.Net.Sockets.Socket.DoBind(EndPoint endPointSnapshot, SocketAddress socketAddress)

This either indicates your IPv4 adress is an IPv6 address
( completely unsupported, Opensim doesnt understand / have any support for IPv6 at all )
Or you made a typo in there.
Think of :
* comma's instead of periods,
* FQDN with http or https in front
* Ip octets that dont exist ( EG 10.359.666.888 or so ).
* or you've just hit enter, and didn't put any public address in regions.ini

Mind that Opensim expects to connect on the IP address / FQDN listed in regions.ini


Top
 Profile  
 
Display posts from previous:  Sort by  
Post a new topicPost a reply Page 1 of 1   [ 2 posts ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron


Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
610nm Style by Daniel St. Jules of Gamexe.net