osgrid.org
https://forums.osgrid.org/

Firestorm moves more towards Opensim
https://forums.osgrid.org/viewtopic.php?f=40&t=4284
Page 2 of 2

Author:  Han Held [ Mon Sep 03, 2012 10:09 pm ]
Post subject:  Re: Firestorm moves more towards Opensim

Dolph Gehlbard {L_WROTE}:
There is a problem with attempting to establish a new login URL on the grid manager.
If you're running a standalone version of opensimulator (with hypergrid enabled),
the grid manager will reject any attempts to establish your paremters with the exception
of local host. This is not acceptable.

I had a similar problem when I was setting up my own grid a couple of days ago.
It turned out to be a dns problem on my end.
Once I fixed the dns problem, I could add the grid to the grid manager just fine.

Author:  Pak Haedong [ Tue May 21, 2013 4:17 pm ]
Post subject:  Re: Firestorm moves more towards Opensim

Han,

Can you share with us what the DNS problem was and how you fixed it? I'd love to be able to use a mesh enabled viewer on my stand-alone, but the damned viewers will NOT accept the IP address of the machine on my network which is running the simulator.

Thanks,

Pak

Author:  Pak Haedong [ Wed May 22, 2013 4:52 pm ]
Post subject:  Re: Firestorm moves more towards Opensim

Thank you Kahn and Han,

I don't think I have a NAT/loopback problem, as I can access my regions on OSGrid.

Now I just need to figure out what is meant by "logging in to no-ip"

Pak

Author:  Pak Haedong [ Thu May 23, 2013 4:40 pm ]
Post subject:  Re: Firestorm moves more towards Opensim

Ah, thanks! I will try that.

Pak

Author:  Dolph Gehlbard [ Sat Sep 06, 2014 11:30 am ]
Post subject:  Re: Firestorm moves more towards Opensim

I need an answer.
Has the firestorm development team fixed the "Standalone" issues?
Because, the last time I tried firestorm (and singularity too for that matter), they both listed grids just fine.
The catch is when you're trying to set up your own login URI (in a standalone configuration) that the information doesn't take nor is it recognized as anything valid.
This is why I've ended up using exclusively Cool VL Viewer. (Forget the SL viewer .. and even if it's open sourced, they've closed it off).

Author:  Jim Martin [ Sat Sep 06, 2014 4:35 pm ]
Post subject:  Re: Firestorm moves more towards Opensim

Dolph Gehlbard {L_WROTE}:
I need an answer.
Has the firestorm development team fixed the "Standalone" issues?
Because, the last time I tried firestorm (and singularity too for that matter), they both listed grids just fine.
The catch is when you're trying to set up your own login URI (in a standalone configuration) that the information doesn't take nor is it recognized as anything valid.
This is why I've ended up using exclusively Cool VL Viewer. (Forget the SL viewer .. and even if it's open sourced, they've closed it off).


Hi Dolph,
I am successfully using Firestorm to connect to a standalone that is running on a different computer on my local network, but initially I had the same problem.

I resolved the problem by adding the proper entries in my StandaloneCommin.ini file (located in bin/config-include
I added the following entries under the [GridInfoService] section:

login = http://opensim.mynetwork.local:9000/
gridname = "MyStandAloneGrid"
gridnick = "mySAG"
welcome = http://opensim.mynetwork.local/mwi/public/welcome
register = http://opensim.propheads.com/mwi/public/signup

Note: Change "opensim.mynetwork.local" to the hostname of your sim. Also, I am using mwi so you may not need or want all of the above entries.

I then made sure that the DNS server for my local network had a proper entry for opensim.mynetwork.local that pointed to my opensim server.

Once I had these entries in place, I was able to add an entry for my standalone to Firestorm's grid manager without a hitch.

If you didn't want to mess with DNS, and were only concerned with local network access, you could probably use an IP address instead of a hostname.

Good Luck!

Jim

Author:  Sylvia Sonoda [ Mon Sep 08, 2014 3:29 am ]
Post subject:  Re: Firestorm moves more towards Opensim

I am still very happy with my "Cool VL Viewer". A V3 viewer with a V1 user interface :)
Runs on SL and OpenSim based grids.

Author:  Dolph Gehlbard [ Sat Aug 15, 2015 12:46 pm ]
Post subject:  Re: Firestorm moves more towards Opensim

Jim Martin {L_WROTE}:
Dolph Gehlbard {L_WROTE}:
I need an answer.
Has the firestorm development team fixed the "Standalone" issues?
Because, the last time I tried firestorm (and singularity too for that matter), they both listed grids just fine.
The catch is when you're trying to set up your own login URI (in a standalone configuration) that the information doesn't take nor is it recognized as anything valid.
This is why I've ended up using exclusively Cool VL Viewer. (Forget the SL viewer .. and even if it's open sourced, they've closed it off).


Hi Dolph,
I am successfully using Firestorm to connect to a standalone that is running on a different computer on my local network, but initially I had the same problem.

I resolved the problem by adding the proper entries in my StandaloneCommin.ini file (located in bin/config-include
I added the following entries under the [GridInfoService] section:

login = http://opensim.mynetwork.local:9000/
gridname = "MyStandAloneGrid"
gridnick = "mySAG"
welcome = http://opensim.mynetwork.local/mwi/public/welcome
register = http://opensim.propheads.com/mwi/public/signup

Note: Change "opensim.mynetwork.local" to the hostname of your sim. Also, I am using mwi so you may not need or want all of the above entries.

I then made sure that the DNS server for my local network had a proper entry for opensim.mynetwork.local that pointed to my opensim server.

Once I had these entries in place, I was able to add an entry for my standalone to Firestorm's grid manager without a hitch.

If you didn't want to mess with DNS, and were only concerned with local network access, you could probably use an IP address instead of a hostname.

Good Luck!

Jim



What you're showing there is :
welcome = http://opensim.mynetwork.local/mwi/public/welcome
register = http://opensim.propheads.com/mwi/public/signup

These are two parameters that I don't use since I am using a strict http:// xxx.xxx.xxx.xxx:9000 login URI (externally seen) for a standalone configuration and using the Singularity viewer now since it was upgraded to handle varregions. (It doesn't have this problem). I put in the login URI and the "grid name" (which is m001). Singularity accepts this.
Also, I'm not running it in grid mode which is apparently what the Firestorm viewer is looking for. Therefore the welcome and register URLs you mentioned. Since I don't have those external lookups, the entry fails to register.
Firestorm cannot accept it since it also searches for those other parameters you mentioned.
Since you mentioned it, what exactly is MWI?

Page 2 of 2 All times are UTC - 5 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/