Change font size
It is currently Fri Jul 19, 2019 3:37 pm

Forum rules


{L_IMAGE}
Please only post about software that directly relates to opensim, thank you.



Post a new topicPost a reply Page 1 of 1   [ 6 posts ]
Author Message
 Post subject: Problems with OfflineMessageModule!
PostPosted: Thu Jul 21, 2011 1:35 am 
Furious Typer

Joined: Sun Nov 09, 2008 10:14 pm
Posts: 59
I seam to have problems with the offline message module. I'm pretty sure I have it set right but I will go through the steps:

http://download.osgrid.org/offline_im.zip
I extract this and throw it on my website on the grid. I configure SQL and also create user/pass/database and execute the sql file.


http://download.osgrid.org/OpenSimProfile.Modules.dll
I put this on my regions server the one you run opensim.exe


When I login this the error I get:

{L_CODE}:
02:33:47 - [LLCLIENTVIEW]: Caught exception while processing OpenMetaverse.Packets.RetrieveInstantMessagesPacket for Kane Hart, Object reference not set to an instance of an object   at OpenSim.Region.CoreModules.Avatar.InstantMessage.OfflineMessageModule.RetrieveInstantMessages (IClientAPI client) [0x00000] in <filename unknown>:0
  at OpenSim.Region.ClientStack.LindenUDP.LLClientView.HandleRetrieveInstantMessages (IClientAPI sender, OpenMetaverse.Packets.Packet Pack) [0x00000] in <filename unknown>:0
  at OpenSim.Region.ClientStack.LindenUDP.LLClientView.ProcessSpecificPacketAsync (System.Object state) [0x00000] in <filename unknown>:0



The database stores nothing at all.


Here is my OpenSim.ini:

{L_CODE}:
[Messaging]
    ;# {OfflineMessageModule} {} {Module to use for offline message storage} {OfflineMessageModule *}
    ;; Module to handle offline messaging. The core module requires an external
    ;; web service to do this. See OpenSim wiki.
    OfflineMessageModule = OfflineMessageModule

    ;# {OfflineMessageURL} {OfflineMessageModule:OfflineMessageModule} {URL of offline messaging service} {}
    ;; URL of web service for offline message storage
    OfflineMessageURL = http://godcraft.com/os/offlineim

    ;# {MuteListModule} {OfflineMessageModule:OfflineMessageModule} {} {} MuteListModule
    ;; Mute list handler (not yet implemented). MUST BE SET to allow offline
    ;; messages to work
    MuteListModule = MuteListModule

    ;# {MuteListURL} {OfflineMessageModule:OfflineMessageModule} {} {} http://yourserver/Mute.php
    ;; URL of the web service that serves mute lists. Not currently used, but
    ;; must be set to allow offline messaging to work.
    MuteListURL = http://godcraft.com/os/mute

    ;; Control whether group messages are forwarded to offline users.
    ;; Default is true.
    ;; This applies to the core groups module (Flotsam) only.
    ; ForwardOfflineGroupMessages = true




please note I have tried disabling mute and I have also tried http://godcraft.com/os/offlineim to http://godcraft.com/os/offlineim/index.php directly to the index but not need since the htaccess file redirects. ALSO I have tried removing that haha.


I have set up search, groups, and Profile just fine so far. This the only one thats has problems for me.


This is also using latest Release version of Opensim 7.1 is it?

_________________
[Kane_Hart] on IRC!


Top
 Profile  
 
 Post subject: Re: Problems with OfflineMessageModule!
PostPosted: Thu Jul 21, 2011 4:08 am 
OSG Elite
User avatar

Joined: Sat Nov 06, 2010 10:19 am
Posts: 1047
Location: Czech Republic
Hello,
the messages exchanged between sim and the service has been changed. I was unable to find documentation to the Osgrid version.

Use the most recent stable version (0.7.1.1) from http://opensimulator.org/wiki/Download on your grid and everything will work fine for you.

Bo


Top
 Profile  
 
 Post subject: Re: Problems with OfflineMessageModule!
PostPosted: Thu Jul 21, 2011 2:25 pm 
Furious Typer

Joined: Sun Nov 09, 2008 10:14 pm
Posts: 59
Bo Iwu {L_WROTE}:
Hello,
the messages exchanged between sim and the service has been changed. I was unable to find documentation to the Osgrid version.

Use the most recent stable version (0.7.1.1) from http://opensimulator.org/wiki/Download on your grid and everything will work fine for you.

Bo


Hello I am using 7.1.1 now. I think the php script might be causing the issue. A unrelated to maybe related issue I saw on the Mantis from Mel:
http://opensimulator.org/mantis/bug_vie ... ug_id=4019


{L_QUOTE}:
This is not a viewer crash. It's a session crash. It happens when the PHP part returns something that is not a .NET object. Check your server error log for php errors and fix the server configuration according to what you find there. This is most commonly caused by database issues or missing PHP plugins.

_________________
[Kane_Hart] on IRC!


Top
 Profile  
 
 Post subject: Re: Problems with OfflineMessageModule!
PostPosted: Thu Jul 21, 2011 3:19 pm 
OSG Elite
User avatar

Joined: Sat Nov 06, 2010 10:19 am
Posts: 1047
Location: Czech Republic
Hello,
well situation is not that easy how it sounds. There can be 2 reasons of problems
1) the protocol is wrong (that would be if you would use the current osgrid version with old php file)
2) the offline message is installed wrongly

While you swapped to the 0.7.1.1 second option is more realistic. Then you need understand what is called by the module. That
{L_CODE}:
http://godcraft.com/os/offlineim

is in fact a FOLDER. While the module sends messages it calls adress:
{L_CODE}:
http://godcraft.com/os/offlineim/SaveMessage/

and while retrieves it calls
{L_CODE}:
http://godcraft.com/os/offlineim/RetrieveMessages/


The script uses variable
{L_CODE}:
$method = $_SERVER["PATH_INFO"]

to see what function you are calling thanks to comparations like this:
{L_CODE}:
if ($method == '/offline/SaveMessage/') {


I would recommend you to log the $method values into DB to see if is the script called properly.

Bo

PS:maybe just rename the location to "offline" could help. Anyway fixing of the paths in the if statement will help very likely ;)


Top
 Profile  
 
 Post subject: Re: Problems with OfflineMessageModule!
PostPosted: Thu Jul 21, 2011 6:07 pm 
Furious Typer

Joined: Sun Nov 09, 2008 10:14 pm
Posts: 59
Ahh thanks. I been in the process of setting up the 7.2.dev bins anyways now. I rather do that i mean I will be running much smaller scale grid anyways and I'm always for trying things even with possible bad bugs.

I will let you know if it works then and try your methods also.

_________________
[Kane_Hart] on IRC!


Top
 Profile  
 
 Post subject: Re: Problems with OfflineMessageModule!
PostPosted: Thu Jul 21, 2011 11:31 pm 
OSG Elite
User avatar

Joined: Sat Nov 06, 2010 10:19 am
Posts: 1047
Location: Czech Republic
You are welcome.

Sure, while you don't do a production level grid it is best test all the new HG features implemented. If you manage to start offline messages with 7.2 let me know, please.

Bo


Top
 Profile  
 
Display posts from previous:  Sort by  
Post a new topicPost a reply Page 1 of 1   [ 6 posts ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  


Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
610nm Style by Daniel St. Jules of Gamexe.net