Change font size
It is currently Wed Jul 24, 2019 3:31 am

Forum rules


{L_IMAGE}
Please only post about software that directly relates to opensim, thank you.



Post a new topicPost a reply Page 1 of 2   [ 11 posts ]
Go to page 1, 2  Next
Author Message
 Post subject: [WARNING]: EOC marker not found. Codestream is corrupted.
PostPosted: Mon Oct 05, 2009 8:33 am 

Joined: Sun Aug 02, 2009 10:24 am
Posts: 16
I upgraded to the new version yesterday and everything seems ok, except for bending knee.
sometime between last night and now, it crashed. And today, I cannot get it start.
It terminated with a warning [WARNING]: EOC marker not found. Codestream is corrupted.

Can somebody help please?


Top
 Profile  
 
 Post subject: Re: [WARNING]: EOC marker not found. Codestream is corrupted.
PostPosted: Wed Oct 07, 2009 7:20 am 

Joined: Wed Oct 07, 2009 7:15 am
Posts: 8
Yesterday I got the same message as you on one of my regions, but the region didn't crash. As it's only a WARNING I don't think that the warning has anything to do with your region crash.


Top
 Profile  
 
 Post subject: Re: [WARNING]: EOC marker not found. Codestream is corrupted.
PostPosted: Wed Oct 07, 2009 11:24 am 
Site Admin
User avatar

Joined: Sun Feb 22, 2009 1:39 pm
Posts: 395
Location: Wisconsin, USA
I've gotten that also, without crashing.

If you crash, the relevant info to look at would be at the point the red text starts in the console, including the last 2 or 3 lines before this and perhaps 5-10 lines after the red text starts.

Try posting that here to see if someone can make sense of it.


Top
 Profile  
 
 Post subject: Re: [WARNING]: EOC marker not found. Codestream is corrupted.
PostPosted: Wed Sep 14, 2011 9:43 pm 
Furious Typer
User avatar

Joined: Mon Oct 25, 2010 7:42 pm
Posts: 229
Location: Canada
OK I've now gotten the message too. I didn't crash my standalone but it was running horridly. What does the message mean? Did something break? Should I delete and reinstall the program?


Top
 Profile  
 
 Post subject: Re: [WARNING]: EOC marker not found. Codestream is corrupted.
PostPosted: Thu Sep 15, 2011 3:39 am 
OSG Elite
User avatar

Joined: Sat Nov 06, 2010 10:19 am
Posts: 1047
Location: Czech Republic
This may be related to these old bugs:
http://opensimulator.org/mantis/view.php?id=4331
http://opensimulator.org/mantis/view.php?id=4652

Maybe the bugs returned maybe is it new bug. Maybe you need only remove bad asset(sculpt) from the sim.

It looks like a damaged image file to me. Please, obey Key's recommendation and post the lines here so we can see what is the problem.

Thanks, Bo


Top
 Profile  
 
 Post subject: Re: [WARNING]: EOC marker not found. Codestream is corrupted.
PostPosted: Thu Sep 15, 2011 1:33 pm 
Furious Typer
User avatar

Joined: Mon Oct 25, 2010 7:42 pm
Posts: 229
Location: Canada
For some reason I wasn't able to copy and paste the text however I was in between on an oar overwrite so maybe something glitched. I shut it all down and restarted with a clean overwrite and I haven't gotten the message again. Sorry I don't have the text with the specifics.


Top
 Profile  
 
 Post subject: Re: [WARNING]: EOC marker not found. Codestream is corrupted.
PostPosted: Thu Sep 15, 2011 3:23 pm 
OSG Elite
User avatar

Joined: Sat Nov 06, 2010 10:19 am
Posts: 1047
Location: Czech Republic
What matters is that it does not appear again. Maybe it was just temporal.

Otherwise the log could be also obtained from /bin/OpenSim.log

Bo


Top
 Profile  
 
 Post subject: Re: [WARNING]: EOC marker not found. Codestream is corrupted.
PostPosted: Mon Sep 19, 2011 3:24 pm 
OSG Elite

Joined: Tue Dec 21, 2010 8:01 pm
Posts: 362
I get these fairly regularly. I don't know what they are however.

_________________
Walter Balazic
Littlefield Systems
http://www.lfgrid.com


Top
 Profile  
 
 Post subject: Re: [WARNING]: EOC marker not found. Codestream is corrupted.
PostPosted: Sat Oct 08, 2011 6:52 am 
Furious Typer
User avatar

Joined: Mon Oct 25, 2010 7:42 pm
Posts: 229
Location: Canada
OK once again I didn't grab the text, however I've figured out a pattern when these messages consistently occur. For me, it's when I'm switching from one OAR to a new one on my stand alone. It doesn't seem to stop the program from working and the next time I log into the program with the new OAR already installed I don't get the message anymore and all is good.


Top
 Profile  
 
 Post subject: Re: [WARNING]: EOC marker not found. Codestream is corrupted.
PostPosted: Sun Dec 02, 2012 9:36 pm 
Furious Typer

Joined: Sun Nov 22, 2009 5:28 pm
Posts: 68
I just where with my nose on the console when someone teleported in. i see a lot of

2012-12-03 03:26:55,377 WARN - OpenSim.Region.CoreModules.Agent.TextureSender.J2KDecoderModule [J2KDecoderModule]: CSJ2K threw an exception decoding texture 41118a9b-bd1b-4692-9a5e-7a8a5dd90b45: Error while reading bit stream header or parsing packets.

2012-12-03 03:26:55,393 WARN - OpenSim.Region.CoreModules.Agent.TextureSender.J2KDecoderModule [J2KDecoderModule]: Failed to decode layer data for texture 41118a9b-bd1b-4692-9a5e-7a8a5dd90b45, guessing sane defaults

errors appear yellow on the console, between them i see also EOC marker not found. Codestream is corrupted. appear, in the past it only happend with bad oar or database. but this came after someone teleported in. Still curius what it meansthis time ?

It looks like this person maby came from Hypergrid.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post a new topicPost a reply Page 1 of 2   [ 11 posts ]
Go to page 1, 2  Next


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  


Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
610nm Style by Daniel St. Jules of Gamexe.net