Change font size
It is currently Sat Sep 21, 2019 9:05 pm

Forum rules


{L_IMAGE}
. please keep questions related to an OpenSimulator and OSgrid nature.



Post a new topicPost a reply Page 1 of 1   [ 4 posts ]
Author Message
 Post subject: [XEngine]: Failed to save state of script
PostPosted: Fri Apr 04, 2014 5:57 am 
Furious Typer
User avatar

Joined: Thu Jan 01, 2009 8:58 am
Posts: 154
After upgrading to v0.8.0.aec723b I get intermittent error messages for some scripts with the message [XEngine]: Failed to save state of script.

I get two types of error messages, and they look like this:

{L_CODE}:
2014-04-04 12:41:37,147 ERROR - OpenSim.Region.ScriptEngine.XEngine.XEngine [XEngine]: Failed to save state of script open barrel with fire.smoke, item UUID f0acc8ac-27de-4546-9c52-a450d8818423, prim UUID fa4a11ef-0c3d-4b55-8a94-a871c232e3d9 in Badr Bay.  Exception
System.FormatException: The specified format '0.000000' is invalid
  at System.NumberFormatter.NumberToString (System.String format, System.Globalization.NumberFormatInfo nfi) [0x00000] in <filename unknown>:0
  at System.NumberFormatter.NumberToString (System.String format, Double value, IFormatProvider fp) [0x00000] in <filename unknown>:0
  at System.Double.ToString (System.String format, IFormatProvider provider) [0x00000] in <filename unknown>:0
  at System.String.FormatHelper (System.Text.StringBuilder result, IFormatProvider provider, System.String format, System.Object[] args) [0x00000] in <filename unknown>:0
  at System.String.Format (IFormatProvider provider, System.String format, System.Object[] args) [0x00000] in <filename unknown>:0
  at OpenSim.Region.ScriptEngine.Shared.LSL_Types+LSLFloat.ToString () [0x00000] in <filename unknown>:0
  at OpenSim.Region.ScriptEngine.Shared.Instance.ScriptSerializer.WriteTypedValue (System.Xml.XmlDocument doc, System.Xml.XmlNode parent, System.String tag, System.String name, System.Object value) [0x00000] in <filename unknown>:0
  at OpenSim.Region.ScriptEngine.Shared.Instance.ScriptSerializer.Serialize (OpenSim.Region.ScriptEngine.Shared.Instance.ScriptInstance instance) [0x00000] in <filename unknown>:0
  at OpenSim.Region.ScriptEngine.Shared.Instance.ScriptInstance.SaveState (System.String assembly) [0x00000] in <filename unknown>:0
  at OpenSim.Region.ScriptEngine.XEngine.XEngine.DoBackup (System.Object o) [0x00000] in <filename unknown>:0


{L_CODE}:
2014-04-04 12:33:37,094 ERROR - OpenSim.Region.ScriptEngine.XEngine.XEngine [XEngine]: Failed to save state of script Kerosine Lantern - Big- Zink.Lantern steady flame, item UUID e5b590d8-2fea-4c2b-bd75-c83c1baa4432, prim UUID 621d12b1-4362-49d4-9a9c-71d70afb9097 in Meteora.  Exception
System.FormatException: Invalid Guid format: 05dfadda38b923e4d047edd6b847x207
  at System.Guid..ctor (System.String g) [0x00000] in <filename unknown>:0
  at OpenMetaverse.UUID..ctor (System.String val) [0x00000] in <filename unknown>:0
  at OpenMetaverse.UUID.Parse (System.String val) [0x00000] in <filename unknown>:0
  at OpenSim.Region.ScriptEngine.Shared.Instance.ScriptInstance.SaveState (System.String assembly) [0x00000] in <filename unknown>:0
  at OpenSim.Region.ScriptEngine.XEngine.XEngine.DoBackup (System.Object o) [0x00000] in <filename unknown>:0


It might of course have to do with the fact that I also upgraded to Mono JIT compiler version 3.4.0 ((no/d4511ef Tue Mar 25 14:35:52 EDT 2014), but this is not a new error condition. I just see more of them after this upgrade. Anyone else seeing this and in case do we need to create a Mantis for it?

_________________
RL is the place you end up when you crash.

– running my regions on OS X and PostgreSQL at HG address grid.xmir.org:8002


Top
 Profile  
 
 Post subject: Re: [XEngine]: Failed to save state of script
PostPosted: Fri Apr 04, 2014 4:22 pm 
Site Admin

Joined: Sun Jul 04, 2010 8:20 pm
Posts: 487
Gavin, have you checked to see if the scripts compile fine on one of the sandboxes?

dan


Top
 Profile  
 
 Post subject: Re: [XEngine]: Failed to save state of script
PostPosted: Sat Apr 05, 2014 1:57 am 
Furious Typer
User avatar

Joined: Thu Jan 01, 2009 8:58 am
Posts: 154
The scripts both compile and run fine everywhere, the error message has to do with saving script state.

I also noticed these error messages: [WATCHDOG]: Timeout detected for thread "Heartbeat (Murat River)". ThreadState=Running. Last tick was 7007ms ago.

I probably has more to do with the version of mono than anything else, but it might be worthwhile for someone in the know to look into is since mono 3.4 is a major bug fix version.

_________________
RL is the place you end up when you crash.

– running my regions on OS X and PostgreSQL at HG address grid.xmir.org:8002


Top
 Profile  
 
 Post subject: Re: [XEngine]: Failed to save state of script
PostPosted: Mon Apr 07, 2014 3:25 am 
Furious Typer
User avatar

Joined: Thu Jan 01, 2009 8:58 am
Posts: 154
After reverting back to mono 3.2.7 everything looks normal again.

_________________
RL is the place you end up when you crash.

– running my regions on OS X and PostgreSQL at HG address grid.xmir.org:8002


Top
 Profile  
 
Display posts from previous:  Sort by  
Post a new topicPost a reply Page 1 of 1   [ 4 posts ]


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron


Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
610nm Style by Daniel St. Jules of Gamexe.net